Network question - what is going on here?

0 Members and 1 Guest are viewing this topic. Read 369 times.

Alexdad54

Network question - what is going on here?
« on: 8 Feb 2021, 04:39 pm »
Hi all,
A long-time reader and lurker, I have learned an immense amount from AC, including the support and help I got from nycparamedic in setting up a linux music server via this circle. I have a current problem related to my Bluesound Node 2 and my home network that I can't figure out what's happening and how to resolve it and so I'm coming back to the circle for advice and guidance.

The scenario:
I have a modem and router in the basement that feeds wi-fi and ethernet signals through the house. The ethernet is cabled directly to only 3 rooms via some legacy networking in the house and (among other devices)  I run my Bluesound Node 2  and Elac Navis AR-51 powered speakers via the single ethernet feed in the living room. I have no issues when the ethernet is connected directly to the back of the Node 2, the player is detected on the BlueOS app and I can play tunes sourced from my network NAS which is also in the basement.

The problem arises when I want to insert a 4 port unmanaged switch into the set-up so I can also connect the audio for my, Shield TV, LG Nano TV and Xbox X to the Elacs (via a Topping E30 DAC) as well, using a Decware Zen switch box to divide the two audio feeds.  When I remove the ethernet cable from the Node and plug it into the switch, it shows a signal lighting up but is not/not seen by the BluOS app. Similarly, plugging in the other three sources into the switch has similar results, no ethernet is detected on any of the attached devices although the network map shows wired connections detected. I tried rebooting the router and modem but it didn't alter anything, still no signal detected.

I know the ethernet feed works, because as soon as I reconnect it directly into the Node, it shows up again and plays music again. (The wifi is not/not connected on the Node).

Is there something I'm missing about hooking all these up? I've tried two different switches, a Trendnet TEG-s50G and a newly purchased  TP-Link TL-SG108 to share the sole ethernet internet connection. They both seem to be operating normally although the trendnet lights do indicate with an orange light that the incoming feed is only 10/100m. Could that be the problem? 

Is there another possibility to try? I'm not afraid to dip my toes in changing settings in the routher admin page if needed.  :)

All advice appreciated! 

Mike-48

Re: Network question - what is going on here?
« Reply #1 on: 9 Feb 2021, 03:37 am »
Network stuff can be complex and infuriating.
Have you tried rebooting you router and switches after making the change? IME that can help.

Vincent Kars

  • Jr. Member
  • Posts: 245
  • The Well Tempered Computer
    • The Well Tempered Computer
Re: Network question - what is going on here?
« Reply #2 on: 10 Feb 2021, 11:06 am »
Just a guess, check if you have set a fixed IP for the Bluesound on the router or on the device itself?

Alexdad54

Re: Network question - what is going on here?
« Reply #3 on: 15 Feb 2021, 04:36 pm »
My thanks you both for the suggestions, but it turns out these weren't the issues....!  Finally, after trying everything, it dawned on me to test the main ethernet cable from the wall drop to the switch using my laptop and it seems the cable was  the defective link. :duh:
Now I'm getting regular connections via the switch after swapping out the cables.

richidoo

Re: Network question - what is going on here?
« Reply #4 on: 15 Feb 2021, 08:29 pm »
Glad to hear you found the problem!

Fwiw, I have a couple of those little TP-Link switches and they have always worked well without hiccup.

Mike-48

Re: Network question - what is going on here?
« Reply #5 on: 16 Feb 2021, 03:11 am »
the cable was  the defective link. :duh:
Congratulations on finding that! When that happened to me, several years ago, it took forever to find. A bad cable is the last thing most of us think about.

After that, I bought a cable tester from Amazon. Nice to have it in the closet for use when a gremlin can't be found.

https://smile.amazon.com/gp/product/B000KMHL8M
« Last Edit: 16 Feb 2021, 09:49 pm by Mike-48 »

Alexdad54

Re: Network question - what is going on here?
« Reply #6 on: 17 Feb 2021, 05:18 pm »
Thanks for the link to the tester, it's definitely going to be added to my toolkit! I never figured on the cable going bad. Now I have a heavy-duty Cat 8 cable connected and it seems to be fine. I'm now getting green lights across the board except for my new LG NaNO85 tv which lights up orange - lousy network card I think. For some reason, the TV doesn't see the ethernet connection, just the wifi. Not really needed now though with the Node 2. Xbox X and Shield TV doing all the music and video heavy lifting.....

Also, just FWIW, the new Topping E30 DAC I inserted into the audio chain for video based on the feedback on AC is sounding really good, close to the Node 2! Both play very nice with the Elac Navis speakers. :)
Thanks again to all for your ideas, I'm always learning something new on AC!