ST-10 Input sensitivity problem with tube preamp

0 Members and 1 Guest are viewing this topic. Read 348 times.

audiomaniac

ST-10 Input sensitivity problem with tube preamp
« on: 10 Jan 2021, 02:38 am »
I just received a new ST-10 and I am finding a problem with my tube preamp having too much gain. Has anybody run into this problem and have any suggestions? The ST-10 replaces a tube amp that I am planning to keep so that I can roll the amp I use from time to time. I like the ST-10 but I also like my tube preamp and I didn't have any plans of replacing it. Has anybody tried Rothwell - In-Line Attenuators? I would be afraid that they would trash the sound of the ST-10.

JackD

  • Full Member
  • Posts: 1191
Re: ST-10 Input sensitivity problem with tube preamp
« Reply #1 on: 10 Jan 2021, 03:04 am »
I've never had a problem with the Rothwell's and I have both a SE and Balanced set of them.  The ST-10 is a great little amp but it is hard to pair with most tube preamps due to the gain issue as it really needs one with gain numbers in the single digits. 

audiomaniac

Re: ST-10 Input sensitivity problem with tube preamp
« Reply #2 on: 10 Jan 2021, 03:14 am »
Thanks Jack. Did you put the attenuators between the preamp and amp? I just want to make sure it would be OK to do so with a ST-10. I've never had an amp like this before. I guess I could always order a pair and see how it sounds.

JackD

  • Full Member
  • Posts: 1191
Re: ST-10 Input sensitivity problem with tube preamp
« Reply #3 on: 10 Jan 2021, 03:35 am »
Yes are you planning to use SE or Balanced?  The Balanced version is much longer and heavier and really needs something to prop them up a little. 

audiomaniac

Re: ST-10 Input sensitivity problem with tube preamp
« Reply #4 on: 10 Jan 2021, 03:46 am »
My preamp is an older Quicksilver and only has SE. I can't turn the volume up much past 8 o'clock  :duh:

JackD

  • Full Member
  • Posts: 1191
Re: ST-10 Input sensitivity problem with tube preamp
« Reply #5 on: 10 Jan 2021, 04:03 am »
That sounds about right as the gain is probably somewhere between 15 and 18db.  The SE ones should work for you.

audiomaniac

Re: ST-10 Input sensitivity problem with tube preamp
« Reply #6 on: 10 Jan 2021, 05:17 am »
Thanks!

John

mresseguie

  • Full Member
  • Posts: 4035
  • SW1X DAC + Don Sachs + Daedalus Apollos = Heaven!
Re: ST-10 Input sensitivity problem with tube preamp
« Reply #7 on: 10 Jan 2021, 12:59 pm »
Hi, audiomaniac.

For reference, I've got a tube preamp with left and right gain controls (dials) that makes pairing to different amps a breeze. I'm so glad I kept it (came really close to selling it). I imagine the attenuators Jack mentioned will provide you with much the same control. I hope they work out for you!  :thumb:

Michael

audiomaniac

Re: ST-10 Input sensitivity problem with tube preamp
« Reply #8 on: 10 Jan 2021, 08:38 pm »
Hey Michael

Yes that would be a good solution. Do you mind if I ask what preamp you have?

Thanks

John