Salkstreamer - help turning optical out on

0 Members and 1 Guest are viewing this topic. Read 848 times.

DEP14

  • Jr. Member
  • Posts: 218
Salkstreamer - help turning optical out on
« on: 18 May 2019, 02:50 pm »
So, Jim showed me what to do yesterday when I picked my streamer up but I'm struggling to get my optical output turned on in my streamer.  I thought I did it right, but the optical has no output. (no light at all when optical cable plugged in, or when I hold open the cover to the output.) 

Given my impatience, maybe an off chance someone chimes in this AM before I hear back from Jim.  Here are my screen shots.

Thanks











Saturn94

  • Full Member
  • Posts: 1189
Re: Salkstreamer - help turning optical out on
« Reply #1 on: 18 May 2019, 05:21 pm »
Hmmm.....I just looked at mine to compare and it appears you have it set correctly in Roon audio settings.  :scratch:

What is your Salkstream hooked up to via this optical connection?

While Jim tests units before delivery, it’s possible the optical output has failed.  The power switch failed on mine the first time I used it (it was working fine when Jim tested it before shipment).  Of course it was taken care of promptly.  Though unusual, these things can happen.

DEP14

  • Jr. Member
  • Posts: 218
Re: Salkstreamer - help turning optical out on
« Reply #2 on: 18 May 2019, 05:53 pm »
Hmmm.....I just looked at mine to compare and it appears you have it set correctly in Roon audio settings.  :scratch:

What is your Salkstream hooked up to via this optical connection?

While Jim tests units before delivery, it’s possible the optical output has failed.  The power switch failed on mine the first time I used it (it was working fine when Jim tested it before shipment).  Of course it was taken care of promptly.  Though unusual, these things can happen.

It's hooked up to the DAC in a integrated amp.  But there is no light at all coming through the optical cable, when I hold the little door open to the streamers optical out, no light at all.  So, was hoping I had a setting wrong. 

I know the DAC works as I had my oppo optical running into it just to make sure, and that optical cord has an obvious bright red light on.

Saturn94

  • Full Member
  • Posts: 1189
Re: Salkstreamer - help turning optical out on
« Reply #3 on: 18 May 2019, 10:32 pm »
Just thought of something.  There’s a setup access in the Salkstream (not Roon) via a web browser where you need to make sure you’ve selected to use S/PDIF.  Have you set this?  It may be yours is set to USB (both cannot be used at the same time).

Here’s a screen shot of what I’m talking about




DEP14

  • Jr. Member
  • Posts: 218
Re: Salkstreamer - help turning optical out on
« Reply #4 on: 18 May 2019, 11:09 pm »
Just thought of something.  There’s a setup access in the Salkstream (not Roon) via a web browser where you need to make sure you’ve selected to use S/PDIF.  Have you set this?  It may be yours is set to USB (both cannot be used at the same time).


Ok, just tried that.  Still nothing.  But will try it again.

Saturn94

  • Full Member
  • Posts: 1189
Re: Salkstreamer - help turning optical out on
« Reply #5 on: 18 May 2019, 11:21 pm »
Well dang.  Thought I was into something. :(

DEP14

  • Jr. Member
  • Posts: 218
Re: Salkstreamer - help turning optical out on
« Reply #6 on: 19 May 2019, 12:46 am »
Well dang.  Thought I was into something. :(

I thought you were also!

Thanks for the suggestions, I had not done that so I hoped that it would work. 

Not sure if this is helpful...




maplemusic

  • Jr. Member
  • Posts: 23
Re: Salkstreamer - help turning optical out on
« Reply #7 on: 19 May 2019, 02:14 am »
@OP

May I know why you have two “Salk Streamer” s showing up? The way I see it, I store the destination alias in that audio zone name. For example I have a optical/toslink cable connected to my AVR, which I named “AVR Toslink” and another HDMI cable connected to a HDMI input which I call “AVR HDMI”.

I think since you have defined two destinations with the same name - the output or audio is being streamed back to “Salk Streamer” going by the screen shot you shared.

Can you try renaming the first entry for audio( Digital ALSA ) zone as “Toslink” or some thing other than “ Salk Streamer” and try?

Thanks

Saturn94

  • Full Member
  • Posts: 1189
Re: Salkstreamer - help turning optical out on
« Reply #8 on: 19 May 2019, 02:27 am »
@OP

May I know why you have two “Salk Streamer” s showing up? The way I see it, I store the destination alias in that audio zone name. For example I have a optical/toslink cable connected to my AVR, which I named “AVR Toslink” and another HDMI cable connected to a HDMI input which I call “AVR HDMI”.

I think since you have defined two destinations with the same name - the output or audio is being streamed back to “Salk Streamer” going by the screen shot you shared.

Can you try renaming the first entry for audio( Digital ALSA ) zone as “Toslink” or some thing other than “ Salk Streamer” and try?

Thanks

I didn’t catch that.  Now that I look at his screenshots closer, I see under “Networked” he has “Splayer” enabled.  On mine, Splayer is not enabled under Networked.  Only the digital connection under Connected to Core is enabled.

Could having Splayer enabled in both locations be the issue?

Like you, I have my zones labeled according to the destination, ie iPad, iPhone, AVM20 (my pre/pro), Oppo 103.

Another thought......after selecting S/PDIF in the Salkstream, maybe it needs to be rebooted to take affect?

maplemusic

  • Jr. Member
  • Posts: 23
Re: Salkstreamer - help turning optical out on
« Reply #9 on: 19 May 2019, 03:37 am »
On the very first screen shot, it shows the  audio zone to be played out is "salk streamer". But where does Roon  really play it out to - as there are two "salk streamer"s.

As soon as he changes the audio zone name of ALSA to a different name and choses to play it out to that zone, I think roon will send the signal to that zone and he can see the light glow up in tos link cable and I bet the music start flowing too😄

BTW Jim told me that there is no need to play with the Non Roon interface that comes out of the box if using Roon. Roon is smart enough to recognize all the available outputs and enable them on the streamer.

DEP14

  • Jr. Member
  • Posts: 218
Re: Salkstreamer - help turning optical out on
« Reply #10 on: 19 May 2019, 12:02 pm »
Thanks to both of you for trying to help.

Yes, I went in and renamed things individually thinking that might be the issue.

I'm going to blow away both of my roon installations (phone and computer) and start over here fresh today.

DEP14

  • Jr. Member
  • Posts: 218
Re: Salkstreamer - help turning optical out on
« Reply #11 on: 19 May 2019, 12:26 pm »
Ok,

Here are this AM's screenshots... only audio output I have enabled is the Toslink, so only a single zone.  Still nothing from the streamers digital output.  Tried enabling the s/pdif (and rebooted, though no indicator if it switched or not).







maplemusic

  • Jr. Member
  • Posts: 23
Re: Salkstreamer - help turning optical out on
« Reply #12 on: 19 May 2019, 01:02 pm »
Just wondering if you are running a Roon core on Mac or the Streamer ? In my case, I am running the core on Streamer and just have roon clients on phone, tablet etc..

Your screen shot looks like the song is playing as I see the song is showing :59 seconds. Just for the sake of it, can you try a different optical cable?

At this point, it is better to wait for the response from Jim as he is quite good in pin pointing the issue.

DEP14

  • Jr. Member
  • Posts: 218
Re: Salkstreamer - help turning optical out on
« Reply #13 on: 19 May 2019, 01:27 pm »
Oh yeah, tried a couple opticals etc.

Jim is aware of it.  Probably user error on my end!

(didn't plan on using the optical...) 

Saturn94

  • Full Member
  • Posts: 1189
Re: Salkstreamer - help turning optical out on
« Reply #14 on: 19 May 2019, 03:05 pm »
Well shucky darns!  :x

Hopefully, Jim will have you up and running soon.  He was great getting mine up and running, and again later when I was trying to use HDMI output into my Oppo 103 for multichannel music even though using HDMI is a non standard use of the Salkstream III.  :thumb:

jsalk

Re: Salkstreamer - help turning optical out on
« Reply #15 on: 20 May 2019, 04:46 pm »
Solved.

- Jim

Saturn94

  • Full Member
  • Posts: 1189
Re: Salkstreamer - help turning optical out on
« Reply #16 on: 20 May 2019, 11:22 pm »
Yay!  :thumb:

So what was the solution?

jsalk

Re: Salkstreamer - help turning optical out on
« Reply #17 on: 21 May 2019, 02:33 pm »
Yay!  :thumb:

So what was the solution?

We never got that far.  He switched to a USB input and everything is working fine.

- Jim

Saturn94

  • Full Member
  • Posts: 1189
Re: Salkstreamer - help turning optical out on
« Reply #18 on: 21 May 2019, 04:45 pm »
We never got that far.  He switched to a USB input and everything is working fine.

- Jim

Well darn...was hoping the mystery was solved.  :green:

jsalk

Re: Salkstreamer - help turning optical out on
« Reply #19 on: 21 May 2019, 05:16 pm »
Well darn...was hoping the mystery was solved.  :green:

If you need a solution, I can keep looking for one.  The first thing would be to make sure it isn't muted.  That is easy for me to check if you'd like.

- Jim