Still not getting the gains

0 Members and 1 Guest are viewing this topic. Read 2342 times.

Golden_Era

  • Jr. Member
  • Posts: 29
Still not getting the gains
« on: 27 Oct 2018, 07:07 pm »
Hello, I recently posted about switching/upgrading some of my equipment to take advantage of my moving coil phono preamp.

Switched the turntable out for Pioneer PLX-1000 (Yes a DJ table but highly touted by Stereophile).
I switched the passive preamplifier out for an Aric Audio Unlimited tube preamp. I'm running the stock JJ tubes.
Amplifier is an Odyssey Khartago.

Experimenting with a used cartridge, an Audio Space V-12 moving coil cartridge with about 300 hours on it. specs posted in pic.

Everything is setup up properly however I am struggling to get enough gain. The tube preamp has a gain knob and its maxed with volume knob also maxed. With all this Im still only getting minimum volume and no low end. The phono stage has 60db of gain which I was told here is average. I was hoping the tube preamp would be enough to push it.

Perhaps other problems, cartridge loading issue? Amplifier pairing issue? Tonearm mass? Higher gain tubes? Hoping to learn as I go here.
Thanks for any help!

 

 

sunnydaze

Re: Still not getting the gains
« Reply #1 on: 27 Oct 2018, 07:35 pm »
Something is wrong.  Cart output at .40mV into 60db of gain should be fine.

I use two MC carts with outputs in the .25mV range.  I run them into 3 different phono stages, each with 60db of gain.  Sound with all combinations is robust, dynamic and full, never use line stage volume control more than half open.

Sounds like your rig's overall gain / sensitivity profile is too low.  This can be caused by:

Insensitive speakers,

and/or

amp with low input sensitivity,

and/or

a low gain line stage

If not any of these, then something is broken.

Your line stage has has a rear control knob for amp matching.  I'm guessing this adjusts your line stage gain.  Have you tried using it?  My preamp has the same adjustment and I find it very useful.

Golden_Era

  • Jr. Member
  • Posts: 29
Re: Still not getting the gains
« Reply #2 on: 27 Oct 2018, 08:18 pm »
Ok I figured out the "problem". I actually debated even coming on here to explain due to embarrassment. After swearing upon checking multiple times I just simply had the input rcas in a different spot than the front selector switch. Ugh. Fail. :duh: :duh: If it's any excuse I was up for work at 4am. I guess a nap would have helped  :lol:

I will take this over the alternative any day however. But thanks for the reply anyway. Now its a major listening session. Peace.

sunnydaze

Re: Still not getting the gains
« Reply #3 on: 27 Oct 2018, 08:20 pm »
 :rotflmao:

Done that a few times myself.   Glad it's working for ya.  Enjoy!     :thumb:

Charles Calkins

  • Full Member
  • Posts: 1683
Re: Still not getting the gains
« Reply #4 on: 28 Oct 2018, 10:22 pm »
Ok I figured out the "problem". I actually debated even coming on here to explain due to embarrassment. After swearing upon checking multiple times I just simply had the input rcas in a different spot than the front selector switch. Ugh. Fail. :duh: :duh: If it's any excuse I was up for work at 4am. I guess a nap would have helped  :lol:

I will take this over the alternative any day however. But thanks for the reply anyway. Now its a major listening session. Peace.

  Hey Bro:

          It's 3:21 pm here in Martinez Ca.  Time for my NAP!!!

                                                        Cheers
                                                        Charlie

Golden_Era

  • Jr. Member
  • Posts: 29
Re: Still not getting the gains
« Reply #5 on: 4 Nov 2018, 10:45 am »
They are very valuable for sure!! :)