WTL Amadeus GTA - It does not turn.

0 Members and 1 Guest are viewing this topic. Read 1045 times.

zylo

  • Jr. Member
  • Posts: 16
WTL Amadeus GTA - It does not turn.
« on: 14 Dec 2017, 12:42 pm »
Hi
Again I need a little help - I got my WTA Amadeus GTA from a family where the father died. Therefore they had no knowledge about it, the tone arm was broken and the power supply was gone. Therefore I could get it at a good price. They told me that it should work. I found a 12v, 1a DC power supply and plugged it in - and there is absolutely nothing going on, dead :-( Have any of you looked at the inside of an Amadeus - are there any fuse (doubt it) that could be the problem. It seems fairly easy to unscrew the covers at the underside - guessing that all cables are running in there. Then I can check if it is something basic as a connection or something else easily found. But before I do so, I would like to hear if anyone has tried something like that - and if there are, are there then something that I need to be extra careful about?

Kind regards
Rasmus

mick wolfe

  • Full Member
  • Posts: 624
Re: WTL Amadeus GTA - It does not turn.
« Reply #1 on: 14 Dec 2017, 01:31 pm »
FWIW, the originally supplied wall wart power supply was 12V/1500 ma.  As said before, the only source for a replacement arm I'm aware of is Mike Pranka, the distributor.

zylo

  • Jr. Member
  • Posts: 16
Re: WTL Amadeus GTA - It does not turn.
« Reply #2 on: 14 Dec 2017, 02:17 pm »
Hi Mick

Thanks for the reply back :-) I have talked to Mike and I have also found the tone arm, so just the next obstacle to resurrect the GTA. Yep, did try to different 12V with 1A and 2A. According to instruction it should be above 0.1A. Therefore I am afraid it is on the inside of the GTA (or the plug on the GTA) that is the problem. I am not exactly on my home field on electricity, but I consider a turn table to be fairly simple in relation to motor and wiring...but still damn nervous to open it up ;-)

mick wolfe

  • Full Member
  • Posts: 624
Re: WTL Amadeus GTA - It does not turn.
« Reply #3 on: 14 Dec 2017, 08:07 pm »
Could be the power switch or the motor. Since the tonearm was broke in half, who knows the total damage the table has sustained. Does the platter turn freely for instance?

zylo

  • Jr. Member
  • Posts: 16
Re: WTL Amadeus GTA - It does not turn.
« Reply #4 on: 14 Dec 2017, 08:56 pm »
The platter spins perfectly. The tone arm broke when they moved. Someone put the GTA on the front seat of the car and another one put a box on top of it, as he did not notice it :-/ I better find someone with less then 10 thumbs and ask for help to search for the problem.

sebrof

Re: WTL Amadeus GTA - It does not turn.
« Reply #5 on: 14 Dec 2017, 09:58 pm »
I will ask since you didn't mention: Have you verified that the motor is not turning? Is there a thread (belt)?

gagamut

Re: WTL Amadeus GTA - It does not turn.
« Reply #6 on: 15 Dec 2017, 01:46 am »
may be contact problem

dB Cooper

Re: WTL Amadeus GTA - It does not turn.
« Reply #7 on: 15 Dec 2017, 03:28 am »
Unless you're really confident of your troubleshooting/repair skills, I'd request a shipping box & let the factory do it. With some info and a multimeter, you could check things like whether the motor is getting power to it or not.

zylo

  • Jr. Member
  • Posts: 16
Re: WTL Amadeus GTA - It does not turn.
« Reply #8 on: 15 Dec 2017, 05:10 am »
The motor is not turning. The positive thing, to look at the bright side of life, is that there is no light in the power contact on the front. I hope it indicates that the failure is in the beginning of the the electronic chain and not the engine. But yes, most likely need some one with repair skills to look into it :)

sebrof

Re: WTL Amadeus GTA - It does not turn.
« Reply #9 on: 16 Dec 2017, 01:07 am »
Light on the front of what? I don't have a GTA but I don't have a ight

dB Cooper

Re: WTL Amadeus GTA - It does not turn.
« Reply #10 on: 16 Dec 2017, 02:27 am »
The motor is not turning. The positive thing, to look at the bright side of life, is that there is no light in the power contact on the front. I hope it indicates that the failure is in the beginning of the the electronic chain and not the engine. But yes, most likely need some one with repair skills to look into it :)
So how accessible are the 'guts'? An el cheapo multimeter (and some good guidance with someone familiar with the TT) will tell you whether there is power at both sides of the power switch (and whether power is reaching the motor). That will help Well-Tempered give you an idea what it will cost to fix (and how DIY-friendly that might be). Personally, since the tonearm is hosed anyway, I'd probably just have it done at the factory unless the project is a lot easier than I suspect. An older model TT with two major problems could be up against some cost-effectiveness questions. Good luck.

zylo

  • Jr. Member
  • Posts: 16
Re: WTL Amadeus GTA - It does not turn.
« Reply #11 on: 17 Dec 2017, 10:05 pm »
Thanks for your advice :) From the look of it, then it is fairly easy to get inside it - but I will not do anything before I have someone with more skills by my side. If it seems to be fairly complex, then I agree that the right solution would be to get either the factory or a competent HiFi repair shop to look into it.

zylo

  • Jr. Member
  • Posts: 16
Re: WTL Amadeus GTA - It does not turn.
« Reply #12 on: 8 Feb 2018, 07:15 am »
And it is fixed :) It was the on/off switch, a wire had come loose on it, so nothing major. If any of you are to open your GTA, then be careful when you put it back together, the aluminium is very soft and I threading for two of the screws  :duh:

It is all ready a great upgrade, just need to find a pickup that can match it :)