Nuforce support

0 Members and 1 Guest are viewing this topic. Read 2982 times.

arcticsoul

  • Newbie
  • Posts: 4
Nuforce support
« on: 4 Oct 2014, 12:13 am »
There was another thread about Nuforce support at http://www.audiocircle.com/index.php?topic=128021.0 from last month which is now archived and closed to new comments.

In http://www.audiocircle.com/index.php?topic=128021.0 a few people including me complained about Nuforce support not responding to warranty support requests. nuforcebob, manager of Nuforce CS posted with his contact info and encouraged customers to contact him directly with issues and encouraged complainers to follow up with forums posts reporting that they eventually got their warranty service. Very cool!

Unfortunately I still haven't gotten my AVP-18 back, but here's the timeline so far.

Aug. 27th My Nuforce AVP-18 under warranty stopped powering up and I filed a support ticket.
Aug. 30th No reply after 3 business days, I contacted NuForce CS manager directly.
Sep. 2nd Bob replies, and I also get a response from Nuforce with an RMA. I ship it fedex overnight (I get a sweet discount on this my via employer)
Sep. 3rd according to fedex package tracking, Nuforce received my package
...
Sep. 19th I get an email from Nuforce acknowledging receipt of my unit.
...
Oct. 3rd Still no fix, still no communication, still listening to movies through the speakers in my TV.

@nuforcebob: as you requested, I promise to follow up on the forum when I get service, when that happens.

mresseguie

  • Volunteer
  • Posts: 3303
  • D Sachs amp/pre + Daedalus Audio Speakers = HEAVEN
Re: Nuforce support
« Reply #1 on: 4 Oct 2014, 06:54 pm »
Hi, arctic.

I'm watching this with interest as I, too, own an AVP-18. Fortunately for me, it still works--or it did the last time I used it. I scavenged my AVA Synergy 240/3 amp to combine with my new 2-channel tube preamp to make beautiful music. I should hook it back up in the next week or so. Fingers are crossed.

I hope this all works out for you soon. It almost makes me wish I lived near their operations so I could walk in for a tour to better understand their situation. Just how small an operation are they? And what sort of repair facilities/how many employees are there? What is the hold up?

Michael

P.S. Don't you find it odd that even though you posted once in the other thread and posted once in this thread that your post count is still just one? Must be fuzzy math.  :scratch:

arcticsoul

  • Newbie
  • Posts: 4
Re: Nuforce support
« Reply #2 on: 21 Oct 2014, 06:50 am »
Oct. 20th: Received a replacement AVP-18. An email from Bob at Nuforce explained the 7 week turnaround was due to replacement coming from China.

I suspect it's a refurb as the input names were customized and there were room corrections applied. I reset to defaults before configuring.

I'm also having an odd problem I didn't have with the other one - HDMI video from my computer with GeForce video card thru AVP-18 to TV shows jaggy pixelation in onscreen text. These jaggies don't happen if i leave out the AVP-18 and run the computer straight to the TV over with the same HDMI cable. I have little hope of solving this one - I suspect either this AVP-18 is a bit out of spec or some incompatibility with my setup has emerged in the newer firmware. Has anyone seen anything like this?

7 week turnaround is quite poor. I want to like NuForce as the performance and design is quite nice I'm but not feeling so good about reliability and support after this. It had a 2-year warranty when I bought it, it failed at 13 months, and they've since lowered the warranty period on this unit to 1 year. (Not to mention that 7 weeks ran out quite a bit more of my warranty period)



mresseguie

  • Volunteer
  • Posts: 3303
  • D Sachs amp/pre + Daedalus Audio Speakers = HEAVEN
Re: Nuforce support
« Reply #3 on: 21 Oct 2014, 07:58 am »
Hi. At least you got a 'new' one.

There is another thread I read just today....don't recall which circle, but the suggestion was to make sure the GeForce card's drivers are up to date. It might help. I haven't tried it myself, so I can't offer any constructive advice.

Peace....

arcticsoul

  • Newbie
  • Posts: 4
Re: Nuforce support
« Reply #4 on: 23 Oct 2014, 11:46 pm »
With my replacement AVP-18 I am finding that, strangely, all computer graphics (like OS graphics from my computer with HDMI out, or the display from my Chromecast that I use for all netflix etc., or the native device menus coming from my DVD player) look awful.

However, live action video content looks okay as far as I can see - I suspect this would be an important clue to a video expert but I don't know what it means.

Any of these sources look perfect if i hook them straight up to my TV instead of thru the AVP-18.

Here's the Chromecast straight into the monitor:


Here's Chromecast through AVP-18 into the monitor:


Disregard the different colors in the images - the Chromecast wallpaper changed itself. But look at those jaggies.

This doesn't look like something a bad cable could cause, but just in case I tried a couple different (quality) HDMI cables with no effect.

Anyone seen anything like this or have an insight what could be going on here? Other than simply that the replacement Nuforce AVP-18 I waited 7 weeks for is also broken?

The firmware version on this AVP-18 is 1.52.02.48 - the most recent seems to be 1.52.02.52 which I'll try upgrading to as soon as I can find a Windows pc to apply it with.






arcticsoul

  • Newbie
  • Posts: 4
Re: Nuforce support
« Reply #5 on: 2 Nov 2014, 01:17 am »
A firmware upgrade actually fixed this problem - jaggies are all gone. Could have been a bug in the .48 firmware.