virtue 901 question re power button

0 Members and 1 Guest are viewing this topic. Read 928 times.

turboboy

  • Jr. Member
  • Posts: 9
virtue 901 question re power button
« on: 6 Jul 2011, 03:19 pm »
hi all- my 901 power button is suddenly non operational: it is 'locked' on "stanby", my usual mode when not playing  music.  this happened without warning. power is running to the amp, as the "standby" light is lit. i disconnected and reconnected the battery: no help.

i just discovered that i had a power outage, with power return.  the virtue piano is working fine.  could i have fried the power button? if so, any suggestions for repair?  next steps.

is there any form of 'reset'?

many thanks to all who read/respond.

damn it is hot in boston!

turboboy
« Last Edit: 6 Jul 2011, 04:37 pm by turboboy »

virtue

  • Facilitator
  • Posts: 1197
  • Making audio lovers audiophiles
    • Virtue Audio
Re: virtue 901 question re power button
« Reply #1 on: 6 Jul 2011, 07:56 pm »
Every few months it happens to someone.  Please email Cami - there is a reset sequence that seems to work when the IC locks up.  It's a software bug we cannot fix, nothing fatal.

PSB Guy

Re: virtue 901 question re power button
« Reply #2 on: 6 Jul 2011, 08:13 pm »
FWIW, this happened to me a couple of months ago after a power outage. These are the steps I used to fix it, they are from the manual:
1. Turn off front power button (or turn off by remote)
2. Turn off rear power rocker switch
3. Unplug the power supply from the back of Sensation
4. Wait 90 seconds, allows IC to reset
5. Plug the power supply back in
6. Turn on rear power rocker switch
7. Turn on front power button (or turn on by remote)
Hope this helps.

Cornelis

turboboy

  • Jr. Member
  • Posts: 9
Re: virtue 901 question re power button
« Reply #3 on: 6 Jul 2011, 09:26 pm »
THANKS Cornelis and Virtue for your prompt replies.  I followed the reset sequence and all is now well!
turboy