Unusual Issue: Unable To Access Specific Track - FLAC Streaming

0 Members and 1 Guest are viewing this topic. Read 1558 times.

ctouhey

Novice at discless music; advanced w/computers.

Short: Any Arist or Album, or Album of an Artist is seen and is correctly selectable, except songs.  The track listing from the album is displayed correctly, in order by track. It is possible to navigate to a particular track, but a song other than the selected song plays.  However, will play only songs from the selected album.  Sort of random, can get stuck on the same song, rarely will ever select the song indicated.

Equipment: Dell Quad-Core; 2.5 TB; 12GB RAM.  Hardwire Ethernet to Denon AVP A1HDCI.  Using their Media Server detection (detects DLNA servers and seems to work fine).

Music: At this point just trying to stream small library of FLAC files (less than 400 CDs).  Will worry about pics & videos later.

Background:  Downloaded Asset UPnP.  Burned about 35 CDs to FLAC using dbPoweramp CD Ripper.  Worked perfectly.  About year later, got some extra time and burned another 300 or so CDs, using the same software.  Problem as described in first paragraph manifested itself.

Since then, just listened to CDs.  Now want to create zone to Patio and stream music and control via iPad.  Checked wtih Asset support, who said problem was Denon.  Communicated wtih Denon, who suggested FLAC files were somehow burned differently.  (I tried several albums burned initially, and they all manifest the same issue. Plus, I ripped the rest using the same software with the same settings.)  Replied to Denon and asked them to recommend software they thought would work well with AVP.  They suggested J. River.  Downloaded Saturday, installed Sunday, looks good and imports quickly.  AVP sees their DLNA server (as well as Asset UPnP), but it behaves just as described above.  Can access anything but a specific track.  I would think it was an indexing issue, but Asset says no.

Have also duplicated the FLAC library to Apple Lossless, but don't really know how to mess with iTunes that well, so they're just sitting on another physical drive.

Any suggestions appreciated.

Thanks,
Chris

stereocilia

This may be unrelated to your issue, I have had a few corrupt .flac files, which is worrisome.  I also use dB Poweramp to rip.

firedog

Not sure I understand exactly what your problem is, but will suggest a couple of solutions:

a)it's your ripper, and somehow your FLAC rips are corrupted or not standard. (I had a problem like this once, but only with a few rips): Do a full clean reinstall of dbpoweramp. Make sure you also upgrade to the latest codecs, esp. for FLAC. Consider upgrading to newest version if you don't have it.

b) your server software: clean reinstall latest version of Asset, or try a different UPnP player

Aleg

My guess would be that you disabled your filetype in Asset confguration, maybe check that.

Otherwise I would post the question on dBPoweramp forum. mr Spoon respond often very quick.

-
aleg

ctouhey

Thanks for the quick replies.  I did post first in the dbpoweramp forum, and Spoon did reply, saying he thought it was something in the Denon communication with the DLNA server.  it was the Denon guy who said he thought it was a ripping issue with the FLAC files, and with firedog suggesting the same thing, I think an experiment is called for.

I have upgraded all my dbpoweramp/asset software yesterday.  Will need to check codec.  I need to take a dozen CDs, rip them to a new location, clean out the current library in Asset and point to the new location.  If the tracks become selectable at that point, then that reinforces the file corruption theory.

Before I get started, what is the overall opinion on Asset v. J. River.  Since I'll probably be starting all over, I can begin agin with either.

Thanks,
Chris

ebag4

You might try EAC on a couple of discs and see what it does.  I have never had an issue with the FLAC files it outputs.

http://www.exactaudiocopy.de/

Best,
Ed

ctouhey

Forgot all about that.  Used it some years ago (version 0.9x) along with LAME to make some MP3s for the iPod.  I'll check it out.

ctouhey

Ripped 4 CDs with dbPoweramp CD Ripper.  Same thing.  See the 4 albums fine.  See the 4 artists fine.  Can select any of them.  Can see the tracks, in order.  Can select a track and any track on that album will play.  Worked with Asset.  New versions, new codecs, uninstalled old versions first, etc.

Now I'm just plain mad.

wilbert-vanbakel

  • Jr. Member
  • Posts: 83
  • Photoshopped Smile
    • On Facebook
Just a quick thought: could it be that somehow your playback is configured to shuffle the tracks?

richidoo

Check the ripped tracks directly to make they have good metadata, by using mp3tag, or just hover over the file and dbpoweramp plugin should show a popup of metadata for that track. If the track has title, album, artist, etc, then it must be your library organizer Asset. It could just be that the library database is corrupt in Asset, and you just need to delete the database and point Asset to the music directory to generate a fresh new database. Upgrading the application to new rev. will not regenerate a new database. Even uninstalling it may not delete user data. You may have to find the database file and kill it manually. Meantime, try free foobar to verify that the tracks and correct metadata are available to a player on the network, then you know it is your server.

ctouhey

Good thoughts, richidoo. Sounds like a project for tomorrow evening.  Will defninitely post solution once I figure it out, just in case someone else ever runs into something similar.

Chris

bpape

  • Industry Participant
  • Posts: 4440
  • I am serious and don't call my Shirley
    • Sensible Sound Solutions
One other thing just as a flyer....

When ripping, there is an option to rip it all as one file and just tag the tracks' locations within the file. That would possibly give the behavior you're getting.

Probably not the problem, especially with 2 different tools, but worth checking.

Bryan