KWA 150se going into thermal shutdown

0 Members and 1 Guest are viewing this topic. Read 510 times.

HowardC

  • Newbie
  • Posts: 1
KWA 150se going into thermal shutdown
« on: 11 Oct 2019, 06:29 am »
Hi all,

My ModWright KWA 150se goes into thermal shutdown after an hour or so in the high bias mode.  The amp is ventilated properly and is on spikes with pads on a hardwood floor.  It does not shut down When continuously operated in the low bias mode.

Any Help would be greatly appreciated.


rklein

  • Full Member
  • Posts: 1101
  • My finest audio piece ever!!
Re: KWA 150se going into thermal shutdown
« Reply #1 on: 11 Oct 2019, 03:08 pm »
The amp will probably need to go back to Modwright to fix the problem.  A friend let me borrow his 150SE and it also was shutting down on high bias setting.  I believe that the amp got sent back to Dan who then fixed this problem.

Regards

Randy

RDavidson

  • Full Member
  • Posts: 2513
Re: KWA 150se going into thermal shutdown
« Reply #2 on: 11 Oct 2019, 04:13 pm »
From my Ewok level of technical knowledge, it's probably a thermistor that is overly sensitive or out of spec. Should be an easy fix if that's the case.

billc

  • Jr. Member
  • Posts: 69
Re: KWA 150se going into thermal shutdown
« Reply #3 on: 17 Oct 2019, 04:55 am »
Both my 150SE's were running very warm/hot.  I even put a quiet computer fan near one because I was worried about thermal shutdown, or reduced equipment life.

But, in talking the issue over with Dan, he indicated that he now biases the amp at a lower level.
He brought the high bias setting down on both amps, with absolutely no discernable effect on sound quality.
And both run much cooler now. 

I strongly recommend you talk with him.  His product service is fantastic!

Biil C

Phil A

Re: KWA 150se going into thermal shutdown
« Reply #4 on: 17 Oct 2019, 01:45 pm »
Hi all,

My ModWright KWA 150se goes into thermal shutdown after an hour or so in the high bias mode.  The amp is ventilated properly and is on spikes with pads on a hardwood floor.  It does not shut down When continuously operated in the low bias mode.

Any Help would be greatly appreciated.

What speakers are you using?

Phil A

Re: KWA 150se going into thermal shutdown
« Reply #5 on: 17 Oct 2019, 01:45 pm »
Hi all,

My ModWright KWA 150se goes into thermal shutdown after an hour or so in the high bias mode.  The amp is ventilated properly and is on spikes with pads on a hardwood floor.  It does not shut down When continuously operated in the low bias mode.

Any Help would be greatly appreciated.

PS - Welcome to the forum!

fado

  • Jr. Member
  • Posts: 223
Re: KWA 150se going into thermal shutdown
« Reply #6 on: 17 Oct 2019, 04:20 pm »
How old are your 150SE's?