Plasma TV buzz/ground loop through new phono cable

0 Members and 1 Guest are viewing this topic. Read 247 times.

bajaed

Plasma TV buzz/ground loop through new phono cable
« on: 19 Nov 2018, 01:58 am »
I had this problem a couple years ago but it went away after I unhooked my tt to have it looked at then hooked it back up. 95% gone after that.

I just got a set of ZU Mission phono cables and the buzz is back and louder. It's also there when I unplug the tt walwart.

It goes away when I turn off the tv. When the tv is on, it goes way down when I touch the grounding post and ground wire spade at the turntable. It also goes way down when I touch my Jolida JD9.

I know the ZU is a really good low cost phono cable so I'd like to keep it. I also like watching muted TV when I listen to music(not very purist of me).

Any ideas on how to solve this?

Phil A

Re: Plasma TV buzz/ground loop through new phono cable
« Reply #1 on: 19 Nov 2018, 02:04 am »
Do you live in a high altitude?  I know there are products like the below but not sure if it will solve your issue.

https://avahifi.com/collections/used-demo-and-quick-ship/products/humdinger-dc-line-blocker

bajaed

Re: Plasma TV buzz/ground loop through new phono cable
« Reply #2 on: 19 Nov 2018, 02:10 am »
Not at high altitude. Only change that caused it to come back was phono cable change. Will try to hook old one back up if I cant solve this.

HAL

  • Industry Contributor
  • Posts: 4143
Re: Plasma TV buzz/ground loop through new phono cable
« Reply #3 on: 19 Nov 2018, 02:27 am »
Is the turntable ground connected to the phono preamp ground? 

bajaed

Re: Plasma TV buzz/ground loop through new phono cable
« Reply #4 on: 19 Nov 2018, 03:31 am »
Yes the ground wire is connected at both the tt and the phono pre.

JDoyle

  • Jr. Member
  • Posts: 159
Re: Plasma TV buzz/ground loop through new phono cable
« Reply #5 on: 19 Nov 2018, 03:51 am »
Don’t hate me or sue me for this, but try eliminating the ground on the tt with one of those plugs. Yeah, it’s a minor shock risk (if you’re careless),  but it’ll probably eliminate the hum.
https://www.amazon.com/GE-Polarized-Grounding-Adapter-14404/dp/B00B7PK1TC/ref=asc_df_B00B7PK1TC/?tag=hyprod-20&linkCode=df0&hvadid=167140365824&hvpos=1o1&hvnetw=g&hvrand=4364621539614502974&hvpone=&hvptwo=&hvqmt=&hvdev=t&hvdvcmdl=&hvlocint=&hvlocphy=9005511&hvtargid=pla-305490653880&psc=1

bajaed

Re: Plasma TV buzz/ground loop through new phono cable
« Reply #6 on: 19 Nov 2018, 04:21 am »
So, would I plug the wall wart of the tt motor into that?

JDoyle

  • Jr. Member
  • Posts: 159
Re: Plasma TV buzz/ground loop through new phono cable
« Reply #7 on: 19 Nov 2018, 02:31 pm »
Yes.
They are available at any local hardware store as well as most department stores.
Does your TT have a separate ground to attach to a component?
Older TT models had these attached to the rca’s that you actually ground at the receiver.  What is the brand of your TT?
Your problem might not be a ground loop issue too.

JD

bajaed

Re: Plasma TV buzz/ground loop through new phono cable
« Reply #8 on: 19 Nov 2018, 02:44 pm »
It's a Music Hall 7.1. It has RCA outs and a ground post, not fixed outputs.

Speedskater

  • Full Member
  • Posts: 2199
  • Kevin
Re: Plasma TV buzz/ground loop through new phono cable
« Reply #9 on: 19 Nov 2018, 02:52 pm »
First, try using a good RCA interconnect coax cable with a heavy braided shielded.

bajaed

Re: Plasma TV buzz/ground loop through new phono cable
« Reply #10 on: 19 Nov 2018, 04:25 pm »
Well like I said in the first post, I was using the stock cables it came with, the buzz developed but at some point in unplugging and plugging components back in it went away.

I just got a new ZU Mission Phono cable which is well reviewed and should be much better. But when I installed it, the buzz came back. Talked to ZU and they said their cables are well shielded and they hadn't heard of this happening. They suggested I send it back for evaluation but before I do I'm trying to figure out if it's a ground loop or some other problem not related to the cable.

HAL

  • Industry Contributor
  • Posts: 4143
Re: Plasma TV buzz/ground loop through new phono cable
« Reply #11 on: 19 Nov 2018, 04:38 pm »
Have you tried going back to the original phono cable to see if the noise goes away? 

If so, it is either the connector on the table or the new cable.  Check to make sure there is no corrosion or buildup on the connectors.  Something like Caig Deoxit is good for cleaning them.  Since the noise went away by reconnecting the cable before, might be a good thing to do just for cleaning any build up.