IDA-16 Front Panel Buttons Not Working?

0 Members and 1 Guest are viewing this topic. Read 472 times.

rebbi

  • Full Member
  • Posts: 334
IDA-16 Front Panel Buttons Not Working?
« on: 9 May 2018, 06:26 pm »
I have a quick question about my IDA-16.

Since I typically use the remote control, I hadn't noticed until today that the front panel buttons on my unit don't work at all. For example, if the unit is on standby and I press the power button for 3 seconds, nothing at all happens. Am I missing something or is there a problem with my unit?

rebbi

  • Full Member
  • Posts: 334
Re: IDA-16 Front Panel Buttons Not Working?
« Reply #1 on: 16 May 2018, 02:34 pm »
So, I figured out that the three buttons on the right end of the front face plate (volume down, mute and volume up) do work once I've got the unit powered on with the remote. But the three left side buttons (source left, power on/off, and source right) don't work at all. I’m assuming that nobody else has seen this problem judging by the lack of response to this thread.   :duh:
Anyway, I've been in touch with the NuPrime folks and Jason and his crew are in touch with the folks in Taiwan (I'm in the States) figuring out how to handle this. They've been responsive and I hope to have it resolved soon.   :popcorn:

rebbi

  • Full Member
  • Posts: 334
Re: IDA-16 Front Panel Buttons Not Working?
« Reply #2 on: 21 May 2018, 03:39 pm »
 Update: Jason, Matthew and the gang have been in touch with the factory in Taiwan. They figured out within a few days what the likely culprit is, and they are sending me what I believe to be a replacement PCB and cable that should fix the problem.  They assured me that there is no soldering involved and that my warranty will remain in place. I should be getting the part via FedEx late next week and will report back.
By the way, how do you take the cover off of one of these things? I don’t think I’ve seen screws anywhere on the exterior, unless I have a been looking carefully enough…  :roll:
Kudos to Nuprime for the attentive service.  :thumb:

Wind Chaser

Re: IDA-16 Front Panel Buttons Not Working?
« Reply #3 on: 21 May 2018, 04:00 pm »
By the way, how do you take the cover off of one of these things? I don’t think I’ve seen screws anywhere on the exterior, unless I have a been looking carefully enough…  :roll:
Kudos to Nuprime for the attentive service.  :thumb:

I'm sure they will include instructions. But I found a few picture that might be helpful.  :D






rebbi

  • Full Member
  • Posts: 334
Re: IDA-16 Front Panel Buttons Not Working?
« Reply #4 on: 22 May 2018, 07:49 pm »
Thanks a lot for the photos. They did send me a couple of pages from the repair manual showing how to take the case apart. No photos of the front panel, though, but from what I can see from your pictures it looks like a pretty simple cable connection. We shall see!   :popcorn:

Wind Chaser

Re: IDA-16 Front Panel Buttons Not Working?
« Reply #5 on: 22 May 2018, 08:08 pm »
Hey Steve,

Should you have any questions, I'm sure Jason will see you through. Let us know how it turns out.