Pi3 wifi and bluetooth don't get along :(

0 Members and 1 Guest are viewing this topic. Read 255 times.

randytsuch

Pi3 wifi and bluetooth don't get along :(
« on: 21 Feb 2018, 12:24 am »
My current project is to make a diy bluetooth speaker with a pi3 and an attached dac.

In the process of doing this, I found out there is a "well known" problem with pi3, when you want to use both bluetooth and wifi.  For my application, it caused the audio to stutter. 
So I disabled the internal wifi.  After that, internal bluetooth works fine.

You can have wifi, or bluetooth from the internal sources, but not both.

Is this common knowledge?

If not, your PSA for today.

otto802

  • Jr. Member
  • Posts: 33
Re: Pi3 wifi and bluetooth don't get along :(
« Reply #1 on: 21 Feb 2018, 03:27 am »
What about adding a usb wifi adaptor?

randytsuch

Re: Pi3 wifi and bluetooth don't get along :(
« Reply #2 on: 21 Feb 2018, 03:45 pm »
What about adding a usb wifi adaptor?

I did that last night, found an usb wifi dongle I had bought before, plugged it in, and both wifi and bluetooth work fine now.
I've read you can also use a bluetooth dongle and internal wifi, and it should work too.

But a couple of things.  Some USB wifi dongles draw too much power, and won't work from a pi usb port, so you have to make sure to get one that doesn't need an externally powered usb hub to work.
I have an old patriot that seems to work fine.  There's a list I found here:
https://elinux.org/RPi_USB_Wi-Fi_Adapters#Working_USB_Wi-Fi_Adapters

And then you need to do the following, from an SSH terminal program or from the pi, in terminal mode

Disable internal wifi by editing /boot/config.txt
Code: [Select]
cd /boot
sudo nano config.txt

add these two lines to disable internal wifi , first line is a comment
Code: [Select]
#disable built in wifi
dtoverlay=pi3-disable-wifi
Exit and save

Or if you want to add an external bluetooth module, then disable the internal bluetooth
Code: [Select]
cd /boot
sudo nano config.txt

#disable the internal bluetooth
dtoverlay=pi3-disable-bt

Then also type this to turn off bluetooth
Code: [Select]
sudo systemctl disable hciuart.service

randytsuch

Re: Pi3 wifi and bluetooth don't get along :(
« Reply #3 on: 22 Feb 2018, 08:45 pm »
FWIW, I did a little more research, and it looks like the pi zero w has the same issue.