New hum in previously dead quiet Cornet2 -RESOLVED!

0 Members and 1 Guest are viewing this topic. Read 7731 times.

G E

  • Full Member
  • Posts: 345
New hum in previously dead quiet Cornet2 -RESOLVED!
« on: 28 Jun 2015, 04:31 pm »
Hello,

I have enjoyed my Cornet 2 for a couple years now and it has been very quiet regarding hum and noise.

Friday night I noticed a 60 hz hum out of both channels, the right slightly louder.  It isn't real loud but it is noticeable with no music playing.

I have several sets of tubes and swapped them in, including another Bendix 6106, but the hum remained.

When I turn off the Cornet 2, the downstream electronics are dead quiet, same situation when I select another input on my preamp.  Unplugging the turntable power supply has no effect.

Any ideas?
« Last Edit: 2 Aug 2015, 06:44 pm by G E »

hagtech

  • Facilitator
  • Posts: 2263
    • http://www.hagtech.com
Re: New hum in previously dead quiet Cornet2
« Reply #1 on: 28 Jun 2015, 07:02 pm »
Check your cables.  Often times a broken shield can do this.  Also check ground continuity to all metal parts of the chassis.

jh

G E

  • Full Member
  • Posts: 345
Re: New hum in previously dead quiet Cornet2 -RESOLVED!
« Reply #2 on: 2 Aug 2015, 06:51 pm »
The hum is gone. I disconnect all power cables during severe thunderstorms and when I plugged them back in I may not have got them all back in their previous positions. Ground loop induced hum perhaps.

Any way, I rerouted some power cables and ICs   I also installed a 3" maple platform under my turntable and positioned the cornet 2 180 degrees from original position.

The hum is gone but I can't say with certainty what action was responsible.

The important part is acknowledging the response from Jim Hagerman.

Thank you for taking time to offer help.