Nuforce P9 preamp display flashing

0 Members and 1 Guest are viewing this topic. Read 1324 times.

vitavoxdude

  • Newbie
  • Posts: 2
Nuforce P9 preamp display flashing
« on: 28 Oct 2014, 02:00 pm »
 :(  Anyone else with the same problem?  The display flashes upon startup which is normal as it goes through its tests but it continues indefinitely and no combination of button pushing resolves the problem.  Is there any work around to reset the chip as this is very frustrating.  I feed the Pre via an isolation transformer and I have spike protection too so am mystified why this should happen.

I read someone else just left it for several days and then it was fine again, but this just sounds like running the caps down that retains memory or similar, anyway it does not work for me, I have left it 2 weeks and still no joy.

Is there a trimmer pot or similar that needs tweaking?  Thanks in anticipation.
V

rustydoglim

  • Industry Contributor
  • Posts: 2634
    • www.nuprimeaudio.com
Re: Nuforce P9 preamp display flashing
« Reply #1 on: 29 Oct 2014, 06:44 am »
Try shutting down the P-9, unplug the cable between the display unit and the power supply unit, reconnect the cable back firmly.
This could be due to the loose cable.  If this doesn't work, you need to file a help desk support ticket on NuPrime website.
Please note that all the Nuforce high-end products are under NuPrime, a completely different company.

vitavoxdude

  • Newbie
  • Posts: 2
Re: Nuforce P9 preamp display flashing
« Reply #2 on: 31 Oct 2014, 09:30 am »
 :D Thanks for your reply.  I have already checked the security of cables; I was hoping for a more indepth answer regarding this issue.  The power supply appears good and all caps visually check out with no bulges and no burnt resistors.  As power supplies are usually to blame I am stumped at the display not latching and has me scratching my head.  Is the circuit diagram available for the P9, I could at least fault find with known voltages around the circuit.

I asked for some SE upgrade cap boards for my Nuforce 9v2 amps but Jason said they no longer had any and there was no intention of getting more from hongkong, so built in redundancy if there are issues with your existing boards, a tad worrying IMV and goes against the ethos of being upgradeable which was one of the reasons I bought them. :?