X3 Owners' thread

0 Members and 1 Guest are viewing this topic. Read 19022 times.

Desertpilot

  • Full Member
  • Posts: 530
  • Retired
Re: X3 Owners' thread
« Reply #120 on: 16 Sep 2021, 10:55 pm »
I had a little scare today.  As you know, I purchased a third X3 for center channel duties.  Today, I was playing a Jazz album (CHRIS BOTTI, NIGHT SESSIONS in 5.1 multichannel, DSD 64).  Lots of bass.  As I was listening, I thought the center channel was not producing enough bass.  I felt the rear of the bass driver on all three speakers.  The left and right speakers were pulsing away.  But, the center channel sub was barely moving.  My heart dropped.  I thought I got a defective speaker.  So, I swapped the left and center channel speaker wires.  Whew!  Center channel sub was rockin' and rollin'.  Left channel sub was quiet.  Must be the way the music was mixed.

Marcus

Tyson

  • Full Member
  • Posts: 11207
  • Audio - It's all a big fake.
Re: X3 Owners' thread
« Reply #121 on: 17 Sep 2021, 02:27 am »
I had a little scare today.  As you know, I purchased a third X3 for center channel duties.  Today, I was playing a Jazz album (CHRIS BOTTI, NIGHT SESSIONS in 5.1 multichannel, DSD 64).  Lots of bass.  As I was listening, I thought the center channel was not producing enough bass.  I felt the rear of the bass driver on all three speakers.  The left and right speakers were pulsing away.  But, the center channel sub was barely moving.  My heart dropped.  I thought I got a defective speaker.  So, I swapped the left and center channel speaker wires.  Whew!  Center channel sub was rockin' and rollin'.  Left channel sub was quiet.  Must be the way the music was mixed.

Marcus

Is it hooked to a receiver or an HT pre-pro?  If so, check to make sure the center channel is set to "Full Range".

Desertpilot

  • Full Member
  • Posts: 530
  • Retired
Re: X3 Owners' thread
« Reply #122 on: 17 Sep 2021, 12:41 pm »
Is it hooked to a receiver or an HT pre-pro?  If so, check to make sure the center channel is set to "Full Range".

No pre/pro or receiver.  Music from DAC direct to my amplifier.  It is all good now that I checked and verified sub is working properly.

Marcus

Tyson

  • Full Member
  • Posts: 11207
  • Audio - It's all a big fake.
Re: X3 Owners' thread
« Reply #123 on: 28 Oct 2021, 06:41 pm »
Just got notified, my X3's are being delivered on Monday - woot!!

morganc

Re: X3 Owners' thread
« Reply #124 on: 28 Oct 2021, 07:30 pm »
Just got notified, my X3's are being delivered on Monday - woot!!

Congrats!

Daryl Zero

  • Full Member
  • Posts: 345
Re: X3 Owners' thread
« Reply #125 on: 28 Oct 2021, 08:36 pm »
Just got notified, my X3's are being delivered on Monday - woot!!

Yes, congrats.

Desertpilot

  • Full Member
  • Posts: 530
  • Retired
Re: X3 Owners' thread
« Reply #126 on: 1 Nov 2021, 03:04 am »
Just got notified, my X3's are being delivered on Monday - woot!!

Tyson.  Awesome news.  You are going to love them!

Marcus

doggie

Re: X3 Owners' thread
« Reply #127 on: 29 May 2024, 10:25 am »
Can someone who has a pair of X3's please take a look at the Hypex plate amp and tell me the model number.

It is probably something like FA501

Thanks a lot!

lazbisme

  • Jr. Member
  • Posts: 87
Re: X3 Owners' thread
« Reply #128 on: 29 May 2024, 10:57 pm »
mine is FA251  but I understand there were two different ones used depending on inventory

morganc

Re: X3 Owners' thread
« Reply #129 on: 30 May 2024, 06:08 am »
Mine are the FA251 also. 

doggie

Re: X3 Owners' thread
« Reply #130 on: 30 May 2024, 01:43 pm »
Thanks for the replies. It is appreciated. According to their website Hypex does still carry the FA501.

For someone wanting to replace their problem X3/X5 plate amp this is good news. Also according to David Whitt, Clayton still has the ability and willingness to update the onboard DSP so the amp will integrate with our X3/X5 speakers.