IDA-16 Stuck in protection Mode? Blinking red / solid red

0 Members and 1 Guest are viewing this topic. Read 1755 times.

newaudio11

  • Jr. Member
  • Posts: 10
Today, when I went to turn it on with the remote, there is no click but the little light in front starts flashing red.  Click again, back to the solid red light.  No blue light or click.
The power button on the unit does nothing, but normally I don't use that.  Turn off the power in the back and on and nothing changes.  Does it sound like the power supply is dead or am I missing something?
There were no storms in the area.  It was just on last night. thanks

newaudio11

  • Jr. Member
  • Posts: 10
Re: IDA-16 Stuck in protection Mode? Blinking red / solid red
« Reply #1 on: 28 Apr 2024, 12:14 am »
Well, reply to myself because, upon further investigation, like unplugging everything, changing the cord socket and power again, it did try to click but stayed red.
But I guess it was doing it's job because when I moved it off the shelf, a tablespoon or so of a toxic smelling brown liquid started leaking out of one of the feet or case on the left side.
I guess something melted down.  Time for something new I guess.  Sad it only lasted 5 years. :(


mresseguie

  • Full Member
  • Posts: 4757
  • SW1X DAC+ D Sachs 300b + Daedalus Apollos = Heaven
Re: IDA-16 Stuck in protection Mode? Blinking red / solid red
« Reply #2 on: 28 Apr 2024, 02:03 am »
Based on your description, it sounds like a leaky capacitor. I'll wager it can be repaired for a whole lot less than going out and buying a new amplifier (assuming you wish to keep and not replace it).

newaudio11

  • Jr. Member
  • Posts: 10
Re: IDA-16 Stuck in protection Mode? Blinking red / solid red
« Reply #3 on: 29 Apr 2024, 05:02 am »
Based on your description, it sounds like a leaky capacitor. I'll wager it can be repaired for a whole lot less than going out and buying a new amplifier (assuming you wish to keep and not replace it).
I am leaning this way as well, but I would like to check out which board is causing the issue.
I don't think it would be good to ship or turn upside down with this fluid inside.

So now I will post to see if someone can tell me how to get the case off.

mresseguie

  • Full Member
  • Posts: 4757
  • SW1X DAC+ D Sachs 300b + Daedalus Apollos = Heaven
Re: IDA-16 Stuck in protection Mode? Blinking red / solid red
« Reply #4 on: 29 Apr 2024, 07:15 am »
If I remember correctly, someone once said the screws holding the rubber feet in also hold the case together. [I see you already learned this.] You'll have to experiment with different Phillips head sizes. I've got a multi-tool with quite a few smaller than usual heads that has proved helpful when unscrewing Nuprime remote control cases. [Don't know if this is helpful...]

oskar

  • Full Member
  • Posts: 402
Re: IDA-16 Stuck in protection Mode? Blinking red / solid red
« Reply #5 on: 29 Apr 2024, 03:57 pm »
Hi Newaudio. Sorry to hear about your amp. Mine has been trouble free. I hardly ever power it down. Have you kept yours on like me? I've read that it's ok to keep it powered up and it hardly has any draw when idle. I hope Nuprime will take good care of you.

rustydoglim

Re: IDA-16 Stuck in protection Mode? Blinking red / solid red
« Reply #6 on: 29 Apr 2024, 05:53 pm »
Sometimes the electrolytic capacitor fails after a few years and there is no way to screen for it during production. If you can find a local electronics technician to identify and replace the failed capacitor, the repair would be much cheaper than sending the IDA-16 to our factory for repair.

Your best route is to create a help desk ticket and work with the support staff for the next steps.  Take a photo of the failed area and upload it to the help desk ticket.

oskar

  • Full Member
  • Posts: 402
Re: IDA-16 Stuck in protection Mode? Blinking red / solid red
« Reply #7 on: 14 Jun 2024, 01:36 pm »
Hi newaudio11. 
Did you get your IDA-16 repaired?
I was away for a few weeks and when I tried to power up my amp the red light started blinking erratically. I turned off the rear power switch, waited then tried again. This time no light at all.
I removed the fuse and saw that it had blown. There's a spare fuse in the holder so I put that in, crossed my fingers and tried again. The fuse blew immediately.
Then I remembered your post and hope you can tell me if yours was repaired successfully without having to send it back to Nuprime. Thanks

newaudio11

  • Jr. Member
  • Posts: 10
Re: IDA-16 Stuck in protection Mode? Blinking red / solid red
« Reply #8 on: 15 Jun 2024, 08:54 pm »
Hello,

I guess I should have updated this post that support was helpful when I opened a ticket but man, those screws are quite finicky.
I stripped two getting the feet off and had to order the tool for the stripped screws.  But getting the feet off just removes the bottom thin metal cover,
that allows you to get to the real case where several screws are then removed to allow the top to be pulled off.

Long story short, most of the capacitors on the right side of the power board (matrix board?) were blown and covered nearly the entire interior with fluid.
A huge mess.  I deemed this a no-go to send for repair at this time anyway and closed my ticket.  The only mystery to me, is why it happened in an idle state with no music being played.
I guess it could have been right at some threshold where a little current just blew them.  I really hadn't heard any decrease in sound before that.




oskar

  • Full Member
  • Posts: 402
Re: IDA-16 Stuck in protection Mode? Blinking red / solid red
« Reply #9 on: 16 Jun 2024, 01:35 pm »
Really a bummer. I opened my case and it all looked clean and tidy.
It's with the repairman now and hopefully it's simple matter of replacing some bad caps.
Thanks for getting back and I hope you're up and listening to tunes soon.