Salkstream III gone on network.

0 Members and 1 Guest are viewing this topic. Read 1717 times.

Caustic Casey

  • Jr. Member
  • Posts: 29
  • "All government, of course, is against liberty.."
    • causticcasey.com
Salkstream III gone on network.
« on: 29 Mar 2024, 04:19 pm »
Changed internet providers.  Plugged the stream directly into new router.  Read the manual… as before.  The Salkstream is nowhere to be found.
I feel I’ve lost all options…..

Phil A

Re: Salkstream III gone on network.
« Reply #1 on: 29 Mar 2024, 05:37 pm »
Changed internet providers.  Plugged the stream directly into new router.  Read the manual… as before.  The Salkstream is nowhere to be found.
I feel I’ve lost all options…..

Don't know if the below helps?

https://www.comparitech.com/net-admin/find-network-devices/

Also try Restarting everything (Modem, Router, PC, Streamer, etc.)

newzooreview

Re: Salkstream III gone on network.
« Reply #2 on: 29 Mar 2024, 07:57 pm »
Have you tried another device plugged into the exact same ethernet port on that new router? Using the same ethernet cable?

It sounds like the new router may not be issuing a local IP address to the Salkstream.

When you say "nowhere to be found" does that mean you have opened the web interface for the new router and the new router is not showing the Salkstream in its list of connected devices?

jsalk

Re: Salkstream III gone on network.
« Reply #3 on: 31 Mar 2024, 04:18 pm »
Changed internet providers.  Plugged the stream directly into new router.  Read the manual… as before.  The Salkstream is nowhere to be found.
I feel I’ve lost all options…..

What is likely the cause is that the StreamPlayer's Linux keeps a record of the IP address the original router assigned.  Since you have a new router, it wants to assign an IP address on its own.  So when the StreamPlayer requests its previous IP address, the new router does not recognize it and doesn't assign a new address.

To solve this issue, you will need to hook up a monitor and keyboard to the StreamPlayer.  When you fire it up, you should end up with a prompt.  Enter the username and password from the original documentation.  Once logged in, run the following command:  "sudo ip addr" (without the quotes).  This should result in a list.  Note the item after "2:"  It will be something like "eno1" or "enp3s0" or similar.  Write this down.

Now run the following command:  "sudo dhcpcd -k <NIC>" (without the quotes).  Replace <NIC> with the results you wrote down above.  This will release the IP address currently stored on the unit.  Then run the command: "sudo dhcpcd <NIC>" again replacing <NIC> with the same network interface you wrote down earlier.  This should result in the new router assigning a new IP address to the unit. 

It should then be back to normal.

If you have any quesitons, let me know.

- Jim

Caustic Casey

  • Jr. Member
  • Posts: 29
  • "All government, of course, is against liberty.."
    • causticcasey.com
Re: Salkstream III gone on network.
« Reply #4 on: 7 Jun 2024, 03:02 pm »
I now have my Salkstream hooked up directly to my Imac via cat 5.  I see nothing.

jsalk

Re: Salkstream III gone on network.
« Reply #5 on: 9 Jun 2024, 02:12 am »
Your StreamPlayer needs to be connected to your router, not to a MAC (if I"m understanding you correctly).  Then you can try to connect to the web interface or searched as a device on your network.

If I'm misunderstanding, please provide more details.

- Jim

Caustic Casey

  • Jr. Member
  • Posts: 29
  • "All government, of course, is against liberty.."
    • causticcasey.com
Re: Salkstream III gone on network.
« Reply #6 on: 13 Jun 2024, 04:17 pm »
Hi Jim, hope all is well.
I now have my Salkstream III hooked up to my monitor and keyboard.
I have the prompt, type in the username and password, but Im getting a login error.
I am using the instructions you provided me.
I am trying to assign a new IP, for my new router.

Thanks,
Casey

Caustic Casey

  • Jr. Member
  • Posts: 29
  • "All government, of course, is against liberty.."
    • causticcasey.com
Re: Salkstream III gone on network.
« Reply #7 on: 15 Jun 2024, 06:12 pm »
With the Salkstream terminal up, I can type in the username provided with the documentation, but not the password, which should be splayer, I believe.

I cant go anywhere from there.

Thanks

jsalk

Re: Salkstream III gone on network.
« Reply #8 on: 21 Jun 2024, 06:10 pm »
Casey -

It is hard to assess from a distance on this one.  You may have to send it to me to have a look and address the issue.  Send me an email and I'll send you the address.

- Jim

jsalk

Re: Salkstream III gone on network.
« Reply #9 on: 2 Jul 2024, 01:39 pm »
Casey -

Did you ever get this resolved?

- Jim