WR-100 and DLNA server issues

0 Members and 1 Guest are viewing this topic. Read 6325 times.

rustydoglim

WR-100 and DLNA server issues
« on: 14 Jun 2016, 07:17 am »
Now that we have shipped WR-100 (multi-zone WiFi audio receiver/renderer) and release the NuPrime iOS and Android app, this sticky topic is for discussing all matters related to WR-100, the App, and DLNA.  We will update the website FAQ as we have more answers to frequently asked questions.

The following FAQ will be updated as we have more information.
What DLNA server has been tested with WR-100?
1. Synology
2. Plex

Do you plan to support Tidal?
Yes, we do in future release.
« Last Edit: 14 Jun 2016, 02:36 pm by rustydoglim »

rustydoglim

Re: WR-100 and DLNA server issues
« Reply #1 on: 14 Jun 2016, 02:38 pm »
I installed Plex on MacBook Pro and just tested that it works. I accidentally played loud music to my living room speakers and got a warning from wife!

rustydoglim

Re: WR-100 and DLNA server issues
« Reply #2 on: 14 Jun 2016, 04:24 pm »
Feel free to tell us about your DLNA and NAS setup.  I find that the Synology Diskstation (I have DS213j) easy to use and provide both NAS and media server capability. It is also configured as RAID1 for fault tolerant using dual 4G drives.

For those of you who are not familiar with how it works, instead of going into the technical details, this is what it will provide:
1. A file server on your home network (i.e. NAS) where you can store all your files.  Note that fault tolerant is not the same as back up. Fault tolerant ensures that you never lose your data, even between backups. But only proper backups can create historical versions of your files. I have my photo, video and music files all stored on DS213J.  Since these are data that I don't need to back up, the fault tolerant feature provides enough protection.
For my most precious data, I also copy them to iCloud.

2. Synology provides a lot of tools for playing music and videos remotely on your mobile devices. It also does transcoding - meaning it will convert the video format on the fly to your mobile device.  So I can watch any of the movies from my iPad using the DS Video app.  The recent firmware upgrade is wonderful, the video server pull album art and movie rating from online database, very cool.

WR-100 and NuPrime app
The app can detect DLNA servers on the network (in addition to online services and local music on the phone). To stream music to multiple rooms or to any room, I will have to use WR-100.

HD-AVP (I use HD-AVA since I don't have other amps)
HD-AVA is connected to my NuForce S-9 speakers so when I want to enjoy living room system, the HD-AVA can access the movies and musics from Synology server.  A WR-100 is connected to it for streaming of Spotify music. Apple music gets stream through AirPlay on HD-AVA.

What I can try next is to setup Plex (another media server) on Raspberry Pi (that $39 linux computer). See another topic about this.

jpm

  • Jr. Member
  • Posts: 259
Re: WR-100 and DLNA server issues
« Reply #3 on: 14 Jun 2016, 11:38 pm »
Sounds like a very interesting product - I'll be keeping an eye out for impressions.

BTW - Plex server runs very well on Synology NAS devices (at least it has on my DS1812+ and DS1815+).

It's always worth mentioning the value of a UPS for NAS devices. That inexpensive device which can allow your NAS to shut down gracefully during an outage is well worthwhile!

larsg

  • Jr. Member
  • Posts: 21
Re: WR-100 and DLNA server issues
« Reply #4 on: 19 Jun 2016, 05:51 pm »
Works perfect with Netgear ReadyNAS with firmware 6.5.0

mfwalker1

  • Jr. Member
  • Posts: 7
Re: WR-100 and DLNA server issues - LMS?
« Reply #5 on: 20 Jun 2016, 05:28 am »
Hi,
I have received my WR-100 and I am enjoying exploring the device.
This question may be better answered on the Slimdevices forum, but has any-one had success streaming FLAC from a LMS(7.8 )/Windows server?
It only seems to work with MP3s.
Navigating to a folder containg FLAC files resulted in a 'nothing to play here' message.
I installed PLEX ox on the PC, and there were my FLAC files...
I don't really want to have two DLNA servers running at once.
Regards,
Matt W

rustydoglim

Re: WR-100 and DLNA server issues
« Reply #6 on: 20 Jun 2016, 07:01 pm »
To verify whether this is a Nuprime app or the LMS(7.8 )/Windows server problem, try using another DLNA client.  If the DLNA client app on your smartphone also can't see the files on LMS, then it is the LMS problem.

Bwilson1

  • Jr. Member
  • Posts: 6
Re: WR-100 and DLNA server issues
« Reply #7 on: 1 Jul 2016, 04:33 pm »
I am successful in streaming Rhapsody to the WR-100 but the signal seems to be re-sampled to 48 kHz as this is what is shown on the display of my IDA-8.

Is this correct ?  Why resample ?  Will this be changed in the future to send at the native sampling rate of 44.1 KHz ?

Please advise

rustydoglim

Re: WR-100 and DLNA server issues
« Reply #8 on: 8 Jul 2016, 09:07 am »
Oh, it doesn't get resampled to 48kHz. When IDA-8 was first designed, the digital port was only used for bluetooth dongle, so the display was fixed at 48kHz instead of detecting the actual digital signal's sampling rate.
If you connect WR-100 to DAC-9, it will show the actual sampling rate, up to 96kHz due to limitation of the optical SPDIF.
So don't worry, your high-res music are not being down sampled or re-sampled.
Or you can connect the WR-100 optical output to the optical input of IDA-8, you will see the sampling rate being displayed. Actually you can simultaneously connect the WR-100 digital/power micro USB port to IDA-8 digital port, and WR-100 optical output to IDA-8 input just to compare.

Bwilson1

  • Jr. Member
  • Posts: 6
Re: WR-100 and DLNA server issues
« Reply #9 on: 11 Jul 2016, 01:27 am »
Thanks for the clarification.  Any estimate on when Tidal streaming will be available ?

Thanks
Eric

rustydoglim

Re: WR-100 and DLNA server issues
« Reply #10 on: 11 Jul 2016, 10:35 pm »
There is another bug we are investigating.
For the NuPrime iOS app, for some DLNA servers, it can navigate to directory level but can't see the file. I am sure this can be fixed but we need to duplicate the problem for the app developer (who happens to live in France).

larsg

  • Jr. Member
  • Posts: 21
Re: WR-100 and DLNA server issues
« Reply #11 on: 12 Jul 2016, 07:31 pm »
Have that problem with WAV files ripped by NAIM Unitiserve and HDX on some brands of NAS and DLNA server pc programs. Every file works from my Netgear NAS. No problems with FLAC files.

rustydoglim

Re: WR-100 and DLNA server issues
« Reply #12 on: 13 Jul 2016, 03:53 am »
I had the "files missing" problem with Synology DLNA server prior to the latest update.
Yesterday I upgraded to DSM 6.0.1-7393 Update 1 and it is working now.
So what we can do is to provide a list of supported NAS and its version. And if there is any popular NAS that presents a problem, we can then try to debug it. I was "hoping" that I can duplicate the problem on Synology but with the update the problem was solved.

Hardware: DS216play
DSM version: DSM 6.0.1-7393 Update 1


larsg

  • Jr. Member
  • Posts: 21
Re: WR-100 and DLNA server issues
« Reply #13 on: 13 Jul 2016, 07:12 am »
Did a test with Asset UPnP right now. WAV files ripped with Windows Media Player, EAC and dBpoweramp shows up just fine. WAV files ripped with NAIM and  a program i used to rip a few cd,s on a Mac shows a empty directory. The problem maybe have something to do with ripping programs way to store metadata. It,s not an absolute standard for adding metadata to the end of a wav file.

larsg

  • Jr. Member
  • Posts: 21
Re: WR-100 and DLNA server issues
« Reply #14 on: 13 Jul 2016, 07:15 am »
The same WAV files shows up and plays perfectly from Netgear ReadyNAS 102 with firmware 6.5.1

mervinpearce

  • Jr. Member
  • Posts: 25
Re: WR-100 and DLNA server issues
« Reply #15 on: 8 Aug 2016, 03:51 am »
Using WDShareSpace NAS as a test and plays fine however does not recognize length of audio. (time based)  as it shows 0:00 only.  Touching the image on artwork stops play and does not start again

steveny

  • Jr. Member
  • Posts: 1
Re: WR-100 and DLNA server issues
« Reply #16 on: 22 Nov 2016, 02:25 am »
I configured JRiver Media Center for Mac (22.0.22) running on MacBook-Pro as a DLNA DMS (Server) as well as DMC (instead of using NuPrime app), WR-100 as DMR that connects to IDA-8 with TOS-link optical cable.  The problem happens every time when I start playing an audio track.  IDA-8 is silent while re-locking to the audio tracks, that result in missing the first few second of music.  (i.e., it starts in the middle of music.  :cry:)
It will be nice if WR-100 prep-end a some amount of silent audio signal when start playing, allowing IDA-8 to re-lock, and concatenate the consecutive audio track when the sampling rate is same.
Steven Y.

rustydoglim

Re: WR-100 and DLNA server issues
« Reply #17 on: 24 Nov 2016, 10:26 pm »
The requirement for WR-100 is that you have to use the Nuprime app.  It is not designed for use without the app.

pixelmixture

  • Jr. Member
  • Posts: 35
Re: WR-100 and DLNA server issues
« Reply #18 on: 14 Jan 2017, 12:05 am »
futur tidal support ... future MQA support ?

John Casler

Re: WR-100 and DLNA server issues
« Reply #19 on: 15 Jan 2017, 03:53 pm »
futur tidal support ... future MQA support ?

Qualcomm states it will support TIDAL in the COMING SOON section, but doesn't give a date or timetable.